PostFrontal Forum
PostFrontal Forum
PF Home | International_Forum | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?


 All Forums
 LK8000 International Support
 BUG reporting and solved list
 Declaration issues LX S80
 New Topic  Reply to Topic
Author  Topic Next Topic  

gasseyflyer
Pulcino

7 Posts

Posted - 22/08/2019 :  21:39:14  Show Profile  Reply with Quote
I've just fitted an LX S80. This connects to an LX powermouse IGC. I have joined this to my Oudie running v7 - using the Nano3 driver it seems to work.

However; if I set up and declare a task on the S80 it sends it to the Flarm without issue. But if I declare it on the Oudie it goes to the S80 OK but then I get the message "Flarm error, declaration failed" after several attempts.

I have to change one of the waypoints, declare this then change it back to make it work.

Any ideas?

Alebu
Pulcino

Italy
70 Posts

Posted - 24/08/2019 :  20:01:18  Show Profile  Reply with Quote
Hi gasseyflyer,
I have more or less the same issue with the LXNAV S100.
May you provide more details about your sentence "I have to change one of the waypoints, declare this then change it back to make it work.", please.
Thanks.
Go to Top of Page

AlphaLima
Moderator

Germany
1704 Posts

Posted - 25/08/2019 :  09:30:06  Show Profile  Visit AlphaLima's Homepage  Reply with Quote
??? I'm afraid I don't understand what exactly does (not) Work.
What waypoint name needs to be changed to what?

Can you provide a runtime.log, the waypoint and the task file?


Edited by - AlphaLima on 25/08/2019 16:16:35
Go to Top of Page

gasseyflyer
Pulcino

7 Posts

Posted - 26/08/2019 :  17:46:45  Show Profile  Reply with Quote
quote:
Originally posted by AlphaLima

??? I'm afraid I don't understand what exactly does (not) Work.
What waypoint name needs to be changed to what?

Can you provide a runtime.log, the waypoint and the task file?





Hi

I make the declaration on LK, it sends it to the S80, which then sends to to the Flarm - but with the error message "Flarm error".
To make it work I alter one of the waypoints that the S80 has received to any other point, then back to the original and it declares it on the Flarm without a problem.

If I make the declaration on the S80 and not on LK it sends it to Flarm without a problem.

So... the issue seems to be the way that the S80 handles the declaration file sent from LK8000. There is no error message on LK8000 so I don't know if the error log from LK will help; could I get one off the S80?

Hopefully that is more clear.
Go to Top of Page

Alebu
Pulcino

Italy
70 Posts

Posted - 26/08/2019 :  19:16:42  Show Profile  Reply with Quote
Thanks gasseyflyer, it is more clear to me, now.
Trying to help, let me add some more information about the declaration, even if it is from my Android smartphone running LK8000 7.0, and the LXNAV S100 (throught the OTG IOIO card), by Nano3 driver. Setting a Task in LK8000, having the waypoint A(as start), B, C and D (as Finish) and declaring it, in the S100 the task becames: X (the current position on the airfield, as Start), A (as first WP), B, C, D (as las WP), X (the current position on the airfield, as Finish). Therefore, each time, I have to delete the first and the last point in order to have the correct Task in the S100.

Regards.

Edited by - Alebu on 26/08/2019 19:17:47
Go to Top of Page

gasseyflyer
Pulcino

7 Posts

Posted - 26/08/2019 :  20:19:32  Show Profile  Reply with Quote
Mine adds the same extra start and finish points as well.- I should have mentioned that. I'll try deleting those points like you suggest.

thanks for the advice


quote:
Originally posted by Alebu

Thanks gasseyflyer, it is more clear to me, now.
Trying to help, let me add some more information about the declaration, even if it is from my Android smartphone running LK8000 7.0, and the LXNAV S100 (throught the OTG IOIO card), by Nano3 driver. Setting a Task in LK8000, having the waypoint A(as start), B, C and D (as Finish) and declaring it, in the S100 the task becames: X (the current position on the airfield, as Start), A (as first WP), B, C, D (as las WP), X (the current position on the airfield, as Finish). Therefore, each time, I have to delete the first and the last point in order to have the correct Task in the S100.

Regards.

Go to Top of Page

Marco from Hangar 5
Pterodattilo

Netherlands
840 Posts

Posted - 26/08/2019 :  23:47:20  Show Profile  Reply with Quote
FWIW.. In my setup it works fine (albeit it fails sometimes, which I blame to the wifi connection) I use a wifi connection with the S80 (in stead of the Bt connection like shown in the figures of the below thread), which is wired to the red box flarm via a splittet directly.

What helps is if you can disconnect the RX between the flarm and the flarm display, so there are no bits and bytes coming from the display interfering with the declaration. You can also achieve this by disconnecting the display temporarily during the declaration.. Just give this a try.. if it then works make sure the cable between the Flarm display and the flarm the RX wire (RX at the flarm side) is cut, or gets a switch so you can temporarily disconnect this wire.

Check out my S80 Installation thread how I did this and for pictures and more info about this.

https://www.postfrontal.com/forum/topic.asp?TOPIC_ID=8614&whichpage=1

FWIW 2: With the former Bt as shown in above thread, declaration worked flawless, only now I have this replaced with wifi I need sometimes a second try.. but eventually it works just fine, I can live with that, no problem :-) (I think it interferes with the KRT2 radio connection, that now runs via Bt.. will change that to wifi as well.. The wifi module still has 2 free COM ports I can use for that.)

Marco
BU (PH-588)
Mini Nimbus HS7, s/n 039
http://www.zweef.nl/
Zweefvliegcentrum Noordkop, NETHERLANDS

Edited by - Marco from Hangar 5 on 27/08/2019 00:06:46
Go to Top of Page

gasseyflyer
Pulcino

7 Posts

Posted - 27/08/2019 :  21:44:14  Show Profile  Reply with Quote
Hi, Thanks - the Flarmview is receive only - it doesn't actually transmit to the Flarm (and actually can't as it comes off the flarmsplitter transmit only) so I don't think that can be the problem. Plus if I declare from the S80 it works fine, it's only if I do it on LK on the Oudie so I think it must be the way that LK configures the declaration.

Thanks for your effort though!

quote:
Originally posted by Marco from Hangar 5

FWIW.. In my setup it works fine (albeit it fails sometimes, which I blame to the wifi connection) I use a wifi connection with the S80 (in stead of the Bt connection like shown in the figures of the below thread), which is wired to the red box flarm via a splittet directly.

What helps is if you can disconnect the RX between the flarm and the flarm display, so there are no bits and bytes coming from the display interfering with the declaration. You can also achieve this by disconnecting the display temporarily during the declaration.. Just give this a try.. if it then works make sure the cable between the Flarm display and the flarm the RX wire (RX at the flarm side) is cut, or gets a switch so you can temporarily disconnect this wire.

Check out my S80 Installation thread how I did this and for pictures and more info about this.

https://www.postfrontal.com/forum/topic.asp?TOPIC_ID=8614&whichpage=1

FWIW 2: With the former Bt as shown in above thread, declaration worked flawless, only now I have this replaced with wifi I need sometimes a second try.. but eventually it works just fine, I can live with that, no problem :-) (I think it interferes with the KRT2 radio connection, that now runs via Bt.. will change that to wifi as well.. The wifi module still has 2 free COM ports I can use for that.)

Go to Top of Page

AlphaLima
Moderator

Germany
1704 Posts

Posted - 27/08/2019 :  21:59:52  Show Profile  Visit AlphaLima's Homepage  Reply with Quote
What if you declare a task directly to the Flarmmouse without the S80 and without any flarm display?
We don't know if the Flarm mouse need a Flarm declaration or a Nano declaration protocol.
We still don't have a runtime.log nor the task file.
I don't have a Flarm mouse for testing so I cannot help you without further informations.
Go to Top of Page

gasseyflyer
Pulcino

7 Posts

Posted - 29/08/2019 :  11:56:09  Show Profile  Reply with Quote
Will get the info next time I am at the club, thanks
Go to Top of Page
   Topic Next Topic  
 New Topic  Reply to Topic
Jump To:
PostFrontal Forum © PostFrontal - La community del Volo a Vela Go To Top Of Page
This page was generated in 0.19 seconds. Snitz Forums 2000

Suggerimenti dello staff:

               

Note legali (italiano):
Privacy Policy Cookie Policy
Legal notice (english):
Privacy Policy Cookie Policy

PostFrontal S.A.S. di Giuliano Golfieri & c. - P.I. 05264240960