PostFrontal Forum
PostFrontal Forum
PF Home | International_Forum | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?


 All Forums
 LK8000 International Support
 Development Updates
 new beta version 7.1g
 New Topic  Reply to Topic
Author Previous Topic Topic Next Topic  

AlphaLima
Moderator

Germany
1885 Posts

Posted - 12/01/2020 :  11:04:29  Show Profile  Visit AlphaLima's Homepage  Reply with Quote
new Beta Version 7.1g is available for download:
Android:
https://play.google.com/store/apps/details?id=org.lk8000.test
all other patforms:
https://github.com/LK8000/LK8000/releases/tag/7.1g
Please report any problem relatetd to this version in this thread:

Manual addendum:
https://www.lk8000.it/manual/LK8000_71.pdf


Yotaphone 2, use dithered color.
Support SoftRF Dongle USB device
fix "Next Distance To Radius" for finish turnpoint
add traditional chinese language
workaround GPS week number roll-over
few minor other bug fix and improvements

Edited by - AlphaLima on 12/01/2020 12:27:32

brunotl
Pterodattilo

France
746 Posts

Posted - 19/01/2020 :  13:12:45  Show Profile  Reply with Quote
I have found a critical bug in 7.1g, to avoid problem, please upgrade to 7.1h

Android:
https://play.google.com/store/apps/details?id=org.lk8000.test
all other patforms:
https://github.com/LK8000/LK8000/releases/tag/7.1h

Go to Top of Page

davesalmon
Pterodattilo

United Kingdom
1551 Posts

Posted - 23/01/2020 :  16:37:32  Show Profile  Reply with Quote
I have just updated the old Android phone I use with Condor, to 7.1h. As soon as the data stream starts a message pops up on the screen every few seconds, "Master Time Reset".
As soon as the data stream is stopped by either pausing Condor or starting the Exit process, the message stops. Didn't occur previously, though can't be certain whether it was version f or g.
Go to Top of Page

brunotl
Pterodattilo

France
746 Posts

Posted - 23/01/2020 :  23:13:32  Show Profile  Reply with Quote
quote:
Originally posted by davesalmon

I have just updated the old Android phone I use with Condor, to 7.1h. As soon as the data stream starts a message pops up on the screen every few seconds, "Master Time Reset".
As soon as the data stream is stopped by either pausing Condor or starting the Exit process, the message stops. Didn't occur previously, though can't be certain whether it was version f or g.



can you do a NMEA Log and send it to me ?

Edited by - brunotl on 23/01/2020 23:13:55
Go to Top of Page

davesalmon
Pterodattilo

United Kingdom
1551 Posts

Posted - 23/01/2020 :  23:26:05  Show Profile  Reply with Quote
Will do.
Dave
Go to Top of Page

Robert Haugen
Pulcino

Norway
29 Posts

Posted - 25/01/2020 :  16:14:26  Show Profile  Reply with Quote
quote:
Originally posted by davesalmon

I have just updated the old Android phone I use with Condor, to 7.1h. As soon as the data stream starts a message pops up on the screen every few seconds, "Master Time Reset".
As soon as the data stream is stopped by either pausing Condor or starting the Exit process, the message stops. Didn't occur previously, though can't be certain whether it was version f or g.



I have the same issue.

Robert Haugen
Go to Top of Page

brunotl
Pterodattilo

France
746 Posts

Posted - 25/01/2020 :  16:22:57  Show Profile  Reply with Quote
we have found the problem and publish a new version a 7.1i on GPlay.

Edited by - brunotl on 25/01/2020 16:23:30
Go to Top of Page

Robert Haugen
Pulcino

Norway
29 Posts

Posted - 25/01/2020 :  16:55:59  Show Profile  Reply with Quote
quote:
Originally posted by brunotl

we have found the problem and publish a new version a 7.1i on GPlay.



Sorry, forgot to say.
I use the PC version, which have the same issue.

Robert Haugen
Go to Top of Page

brunotl
Pterodattilo

France
746 Posts

Posted - 25/01/2020 :  17:38:58  Show Profile  Reply with Quote
quote:
Originally posted by Robert Haugen
Sorry, forgot to say.
I use the PC version, which have the same issue.



no problem, others platform are available here :
https://github.com/LK8000/LK8000/releases/tag/7.1i

Go to Top of Page

danielvelez
Falchetto

Colombia
139 Posts

Posted - 27/01/2020 :  03:33:33  Show Profile  Visit danielvelez's Homepage  Click to see danielvelez's MSN Messenger address  Reply with Quote
Hello.

I have a bug on versions g and h, during this weekend flying. Bug seems to be that "head wind" field goes crazy showing big numbers, even getting over the other data fields, and thus the speed to fly speed shows 0, so mccready speed to fly is unusable.

Im using a hisense a2 pro, and connected to a bluetooth airspeed and vario (altair).
Go to Top of Page

AlphaLima
Moderator

Germany
1885 Posts

Posted - 27/01/2020 :  07:50:10  Show Profile  Visit AlphaLima's Homepage  Reply with Quote
OK, thanks for reporting,
I'm afraid we need a NMEA logs of one of your flights to reproduce that.

Edited by - AlphaLima on 27/01/2020 09:54:40
Go to Top of Page

brunotl
Pterodattilo

France
746 Posts

Posted - 27/01/2020 :  14:31:34  Show Profile  Reply with Quote
quote:
Originally posted by danielvelez

Hello.

I have a bug on versions g and h, during this weekend flying. Bug seems to be that "head wind" field goes crazy showing big numbers, even getting over the other data fields, and thus the speed to fly speed shows 0, so mccready speed to fly is unusable.

Im using a hisense a2 pro, and connected to a bluetooth airspeed and vario (altair).





As AlphaLima says, we need the NMEA log...

But if you have external Airspeed, HeadWind is simply "TrueAirSpeed - GroundSpeed"

So problem can come from :
- Bug in External device sending wrong airspeed
- BUG in device GPS reporting a wrong ground speed
- BUG in LK8000 Drivers you use to get data from external device.
- BUG in LK8000 GPS Driver used to get GroundSpeed

for two first we can't do anything, for the two last we need to know witch driver you use and NMEA Log to check what data is really sent by device...

Go to Top of Page

danielvelez
Falchetto

Colombia
139 Posts

Posted - 27/01/2020 :  20:19:57  Show Profile  Visit danielvelez's Homepage  Click to see danielvelez's MSN Messenger address  Reply with Quote
quote:
Originally posted by brunotl

quote:
Originally posted by danielvelez

Hello.

I have a bug on versions g and h, during this weekend flying. Bug seems to be that "head wind" field goes crazy showing big numbers, even getting over the other data fields, and thus the speed to fly speed shows 0, so mccready speed to fly is unusable.

Im using a hisense a2 pro, and connected to a bluetooth airspeed and vario (altair).





As AlphaLima says, we need the NMEA log...

But if you have external Airspeed, HeadWind is simply "TrueAirSpeed - GroundSpeed"

So problem can come from :
- Bug in External device sending wrong airspeed
- BUG in device GPS reporting a wrong ground speed
- BUG in LK8000 Drivers you use to get data from external device.
- BUG in LK8000 GPS Driver used to get GroundSpeed

for two first we can't do anything, for the two last we need to know witch driver you use and NMEA Log to check what data is really sent by device...





Ok. Prior to versions h, and i, the phone worked good. (With the gps workaround at first and then with your special version). I have not updated any firmware on the airspeed sensor or vario sensor, and the phone hasnt updated any "firmware" at all.

If i "replay" the igc, there is no issues with the info and everything works great, but during flight the info was wrong...

Here you can see at the end of this short video, the screen on the instrument, showing looooonng string on the HdWind field and the "Speed to Fly" showing 0.

https://youtu.be/kJkl_hDapUE

I have configured, lower left to Indicated Airspeed as received from the bluetooth feed, and on the lower right, speed to fly.

How can I "make" a nmea log for you guys? Any suggested app for trying it out on the next adventure?

Go to Top of Page

brunotl
Pterodattilo

France
746 Posts

Posted - 27/01/2020 :  21:49:57  Show Profile  Reply with Quote
you video is private, we can't watch it.

in replay, headwinf is calulated using wind estimation in circling, same as if you only use only GPS data.

to make nmea log just go in menu "Config 2/3" -> "NMEA Logger", for each configured device a file is created in "_Logger" folder.



Go to Top of Page

danielvelez
Falchetto

Colombia
139 Posts

Posted - 28/01/2020 :  18:57:48  Show Profile  Visit danielvelez's Homepage  Click to see danielvelez's MSN Messenger address  Reply with Quote
Ok. Video should be public now... I missed a few steps loading it to youtube.

Im gonna try to log the nmea as you suggest and send the feedback then.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
Jump To:
PostFrontal Forum © PostFrontal - La community del Volo a Vela Go To Top Of Page
This page was generated in 0.18 seconds. Snitz Forums 2000

Suggerimenti dello staff:

                                         

Note legali (italiano):
Privacy Policy Cookie Policy
Legal notice (english):
Privacy Policy Cookie Policy

PostFrontal S.A.S. di Giuliano Golfieri & c. - P.I. 05264240960