PostFrontal Forum
PostFrontal Forum
PF Home | International_Forum | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?


 All Forums
 LK8000 International Support
 Hardware
 Connecting FLARM, Vario, Radio via WiFi Interface
 New Topic  Reply to Topic
Previous Page
Author Previous Topic Topic Next Topic
Page: of 6

AlphaLima
Moderator

Germany
1654 Posts

Posted - 27/11/2018 :  12:42:14  Show Profile  Visit AlphaLima's Homepage  Reply with Quote
Ahh, you can record and replay a FLARM NMEAlog to simulate a FLARM.

For watching in prallel you must connect Rx only, two Tx drving against each other will cause problems like framing errros.
So with the PC COM Port Rx you can listen what is sent to FLARM. However, Radio is working bi-directional proves the COM Ports are OK in both directions.
Flarm is OK (proven by the update cable).
So I suspect the ESP <-> FLARM cabeling.
Go to Top of Page

pieterd
Pulcino

9 Posts

Posted - 28/11/2018 :  16:46:59  Show Profile  Reply with Quote
Found the problem. One of my rs232-TTL convertors was defect. Working with a terminalprogram was interresting. Thanks for the help!
Go to Top of Page

pieterd
Pulcino

9 Posts

Posted - 01/12/2018 :  21:56:57  Show Profile  Reply with Quote
In the past I used my Vertika to download log files from my Zander GP940 logger. Is there a possibility to download log files from a Zander GP940 to my smartphone? I understand that LK8000 does not have that option. Connecting the logger via the Wifi interface is not a problem, but one needs a program...
Go to Top of Page

pieterd
Pulcino

9 Posts

Posted - 09/04/2019 :  21:21:37  Show Profile  Reply with Quote
Hi,
Yesterday I made a flight of more than 4 hours. It turned out to be necessary to reset the communication 5 times during this flight. I have a Flarm and a KRT2 radio connected. On de ground, in my garage, the system runs for hours without lost communication. I use LK8000 version 7.1b on a Samsung S5 Neo smartphone. What might be the cause?

Pieter
Go to Top of Page

AlphaLima
Moderator

Germany
1654 Posts

Posted - 09/04/2019 :  21:53:05  Show Profile  Visit AlphaLima's Homepage  Reply with Quote
What is your setup, how is it connected, how do you "reset" communication?
We need a runtime.log, to see what happened.
Go to Top of Page

pieterd
Pulcino

9 Posts

Posted - 10/04/2019 :  10:31:00  Show Profile  Reply with Quote
My KRT2 radio and the Flarm are connected to the Samsung S5 Neo smartphone via the ESP32 SerialBridge, so via WiFi. I reset the communication in the program LK8000, Configuration page number 3, button "Reset Comms". I have sent the Runtime Log to your address: AlphaLima at LK8000.it
Go to Top of Page

Marco from Hangar 5
Pterodattilo

Netherlands
819 Posts

Posted - 01/05/2019 :  17:54:44  Show Profile  Reply with Quote
Hi Alphalima,

Today I made the first flight with your 3 port COM to WiFi bridge..Works fine if it is connected, but I had some trouble to get it connected.

I had the module setup two weeks ago and then it works, but today I get "WiFi connected, no internet", but The TCP client in LK8000 fails to connect.

Tried several times to restart the wifi, it does connect, but the TCP client fails to connect, I also tried to connect via Chrome to 192.168.4.1, but also failed.

But I got it working by "forgetting" the LK8000 WiFi network, and reinitialize again by filling out the password and all that... Then I get to the setup page immediately via 192.168.4.1, and also LK8000 finds immediately the FLARM and S80 Vario. All settings I had made were still there, so that was good.

But is this normal that you have to setup the WiFi connection from scratch every time? I can live with it, But is a bit anoying.

But during flight everything is OK, no problems, I have two way communication with the S80 and I can declare a task into the FLARM unit.

Thanks!

Marco

Marco
BU (PH-588)
Mini Nimbus HS7, s/n 039
http://www.zweef.nl/
Zweefvliegcentrum Noordkop, NETHERLANDS
Go to Top of Page

AlphaLima
Moderator

Germany
1654 Posts

Posted - 02/05/2019 :  10:26:34  Show Profile  Visit AlphaLima's Homepage  Reply with Quote
Thats an Android Issue, try this:
Turn off GSM, Connect to WiFi (eventually Turn On GSM again)!
Go to Top of Page

Marco from Hangar 5
Pterodattilo

Netherlands
819 Posts

Posted - 02/05/2019 :  18:19:27  Show Profile  Reply with Quote
quote:
Originally posted by AlphaLima

Thats an Android Issue, try this:
Turn off GSM, Connect to WiFi (eventually Turn On GSM again)!




OK, will try that next time.. same as putting your phone in aircraft mode and turn on wifi and Bt only.. I did that in the past, but then with Bt only. But with glider tracking the GSM part must be turned on as well to send positions to the server.

Btw, I have forgotten to check if I was visible on Skylines and Glidertracker.org. Will do that next time as well :-)

Marco
BU (PH-588)
Mini Nimbus HS7, s/n 039
http://www.zweef.nl/
Zweefvliegcentrum Noordkop, NETHERLANDS
Go to Top of Page
Page: of 6 Previous Topic Topic Next Topic  
Previous Page
 New Topic  Reply to Topic
Jump To:
PostFrontal Forum © PostFrontal - La community del Volo a Vela Go To Top Of Page
This page was generated in 0.19 seconds. Snitz Forums 2000

Suggerimenti dello staff:

               

Note legali (italiano):
Privacy Policy Cookie Policy
Legal notice (english):
Privacy Policy Cookie Policy

PostFrontal S.A.S. di Giuliano Golfieri & c. - P.I. 05264240960