PostFrontal Forum
PostFrontal Forum
PF Home | International_Forum | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?


 All Forums
 LK8000 International Support
 General Support
 Unknown error on declare to Swiss Flarm
 New Topic  Reply to Topic
Author Previous Topic Topic Next Topic  

jr970
New Entry

United Kingdom
3 Posts

Posted - 12/04/2018 :  16:23:30  Show Profile  Reply with Quote
Just installed LK8000/Oudie in a friends glider. We connected it to his Swiss Flarm unit & it is receiving data OK - I get "FLARM DETECTED" and Barometric altitude and all the FLARM menus are active.

I can also get the Flarm to re-boot OK from the Flarm menu in LK8000, so I think that means communication is two-way.

However when I try to declare a task it fails with "Unknown Error".

I have configured:
Device A as the internal Oudie GPS (Com 1), Generic
Device B as the Flarm (Com 4, 19,200bps). Generic

Any ideas what is causing this ? do I need to have Flarm as Device A? Or could it mean that the Flarm is non-IGC ? ...... glider only just purchased with the Flarm already installed.

Any other ideas ?

AlphaLima
Moderator

Germany
1529 Posts

Posted - 23/04/2018 :  13:22:18  Show Profile  Visit AlphaLima's Homepage  Reply with Quote
As far as I know, non-IGC do not allow Task declarations.
IGC Flarm use to have "IGC approve" stickers on the housing.

You can also find out if it is a IGC Flarm by watching the serial monitor inside LK8000 device Dialog, restart flarm and look init checks written at the serial monitor.
Shuld somehow look like this (IGC + ENL):

Startup: After clean shutdown
o.k. 16 Mbit internal FLASH memory
o.k. ENL
o.k. Obstacles Init
o.k. Logging Init
o.k. UART
o.k. RF subsystem
o.k. Pressure sensor
..........

Edited by - AlphaLima on 23/04/2018 13:56:08
Go to Top of Page

andydasmith
Pulcino

14 Posts

Posted - 25/04/2018 :  20:37:13  Show Profile  Reply with Quote
I have an IGC (Swiss)Flarm connected to a Kobo Touch which is unable to declare a task to the Flarm.
When I change to XCSoar the configuration is able to declare to the Flarm without problems.
I believe there is a problem with the current build.
Go to Top of Page

AlphaLima
Moderator

Germany
1529 Posts

Posted - 26/04/2018 :  16:24:57  Show Profile  Visit AlphaLima's Homepage  Reply with Quote
Is it connected directly to the Kobo or is there a vario or something similar mixing NMEA sentences.
Of so, this is a known problem already fixed for Version after the 7.0 release:
https://github.com/LK8000/LK8000/pull/1182
Go to Top of Page

andydasmith
Pulcino

14 Posts

Posted - 01/05/2018 :  23:24:22  Show Profile  Reply with Quote
I have a Swiss Flarm and a KRT2 radio connected to a Kobo Touch with the latest official LK8000 version through a 4-way usb OTG hub.
This configuration suffered frequent disconnects (buffer under-runs) until I read a post here which mentioned that cheap hubs automatically fall back to the slowest baud rate. Since I have set both to 9600 baud the system appears stable.....but unable to declare
Go to Top of Page

AlphaLima
Moderator

Germany
1529 Posts

Posted - 01/05/2018 :  23:40:03  Show Profile  Visit AlphaLima's Homepage  Reply with Quote
Yes, should also be solved with the above mentioned fix! However 9k6 for FLARM is not a good idea, FLARM disables the traffic data below 19k2Bd due to limited bandwidth.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
Jump To:
PostFrontal Forum © PostFrontal - La community del Volo a Vela Go To Top Of Page
This page was generated in 0.2 seconds. Snitz Forums 2000

Suggerimenti dello staff:

               

Note legali (italiano):
Privacy Policy Cookie Policy
Legal notice (english):
Privacy Policy Cookie Policy

PostFrontal S.A.S. di Giuliano Golfieri & c. - P.I. 05264240960